Error with issuing Gift Cards through the app or web
Incident Report for Appfront
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 11:39 EST
Investigating
Our partners in Valutec is currently investigating this incident. We will update you when this issue is resolved.
Posted Dec 02, 2022 - 10:19 EST
This incident affected: Online ordering.